Fatal Conflict with DIVI

StatusIDPriorityType
Closed31887NormalContent Timeline WP
Profile Reply
Liveby5 Client

HI there.
My client has been using an expired version of this plugin for some time. They were unable to locate the original purchase and this month we needed to update because the old version of the plugin is showing a MySQL vulnerability.

So I’ve turned the old plugin off and installed the new version but it’s throwing a fatal error:
Fatal error: Allowed memory size of 104857600 bytes exhausted (tried to allocate 32 bytes) in /wp-content/themes/Divi/includes/builder/module/field/TextShadow.php on line 130

Now I’ve updated the PHP memory to 256, and basically, when I deactivate the plugin, the error goes away.

Old version (Content timeline v2.35) of the plugin works but is clearly showing a vulnerability that we MUST update.

But the new version breaks the site.

Unfortunately I cannot provide login details as that would be a security breach for my client, however any insight would be most helpful

Replies

User Description Posted On
Shindiri Support team Administrator

Hi,

we can't be sure this is not server related but we want you to try something that can maybe solve this issue.

Please navigate to content_timeline.php file and comment out line 12 that states: ini_set('memory_limit','100M');
so it should look like thisĀ //ini_set('memory_limit','100M');

Path to the fileĀ is \wp-content\plugins\content_timeline\content_timeline.php

Please inform us of the results when you try this.

Thank you

Best regards,
Shindiri Studio | http://www.shindiristudio.com/

Shindiri Support team Administrator

Hi,

any new info about this issue ? Did code we sent sort the problem ?

Thank you.

Best regards,
Shindiri Studio | http://www.shindiristudio.com/

Liveby5 Client

Thank you,
This did not fix the problem. We went on to isolate the problem as a conflict with Stream & Tablepress, both trusted plugins we use so we're now trying to work out how to make them all play fair.

Incidentally, this all came about because the version of the timeline we had keeps reporting a mysql vulnerability

Shindiri Support team Administrator

Hi,

can you please upgrade to latest version of the plugin. 4.4.4 is the version that should be installed as vulnerability you are talking about is sorted few versions ago.

We are awaiting your input about the results.

Best regards,
Shindiri Studio | http://www.shindiristudio.com/

× This ticket is closed.