PrettyPhoto rel on cards image with a no-image URL

StatusIDPriorityType
Closed31131HighContent Timeline WP
Profile Reply
W3B Client

I’d like to link single card images to a pdf (already uploaded in media library), instead of having the fullsize image opened in prettyPhoto lightbox, So, I’ve filled the PHOTO URL field with the absolute link to a pdf file but on frontend, the <a> tag on the card image, still has the “rel=prettyPhoto[timeline]” attribute so clicking on image results in a js alert about missing image, coming from PrettyPhoto.
I’ve already checked “Disable Pretty Photo” on global settings without success.

Furthermore, could be possible to open the content of a card instead, clicking on its image ?

Thanks in advance,
Daniele.
 

Replies

User Description Posted On
Shindiri Support team Administrator

Hi,

there is a chance pretty-photo or similar service  in theme is activating that click since you disabled pretty photo in our plugin. Can you check if that is the case ?

For opening content with image click some customization have to be done and here too is important what style you are using.

We are awaiting your input

Best regards,
Shindiri Studio | http://www.shindiristudio.com/

W3B Client

The theme I'm using includes another lightbox solution, different from PrettyPhoto, and the rel attribute on tag <a> is in the format prettyphoto[timeline-date], exactly the same used by your plugin. I think that probably a check on the URL field is missing somewhere on frontend code and the rel attribute gets printed out regardless.


Regarding the destination of the link on the photo, the inline help on the PHOTO URL input field says "Photo URL can be image, video or site url. Leave it empty to link to full-size image." so I thought there was no need for customization to link to a resource other than the image.

You can see all settings of my timeline in my reply to this ticket

http://support.shindiristudio.com/tickets/missing-month-translations-on-cards-date/

Regards, Daniele.

Shindiri Support team Administrator

Hi,

you might be right about the issue one so we will need access to check more closely. We asked for access in other ticket regarding the same plugin but different issue. If/when you give us that access just refer to all this issues (ticket IDs) we will check all of em.

About the destination link we didn't understand you are talking about main item image. Help is correct. What you need is full link you cant start link from wp-content. Just open the destination file and copy full link of its location to use it.

Best regards,
Shindiri Studio | http://www.shindiristudio.com/

W3B Client

Just to let you know I've already replied to ticket 31129 and sent an email with both ticket IDs in the subject.

Thanks

Shindiri Support team Administrator

Hi,

we confirm we are up to date with that. No worries.
thank you.

Best regards,
Shindiri Studio | http://www.shindiristudio.com/

× This ticket is closed.