Timeline wont display

StatusIDPriorityType
Closed32744HighContent Timeline WP
Profile Reply
uktw Client

https://www.gsmautomotive.com/company/company-history/

I just upgradded to the latest version (4.4.5) from 4.4.1 which worked perfectly but now it wont display at all. Like the previous ticket person I am getting (a) preview works fine and (b) TypeError: $this.find(…).mCustomScrollbar is not a function

Further, on looking at the soyrce I don’t seem to see any of the timeline css loaded?

Replies

User Description Posted On
Shindiri Support team Administrator

Hi,

we are aware that small number of Content Timeline WP users have problem loading some styles and scripts after last update. In last version among bug fixes we added filter for styles and scripts loading only if short-code is present on page. We would like to see if that is causing issue and if so to sort it as fast as possible. So if possible please send us WP login via email to support@shindiristudio.com and team will test and hopefully solve this for you even before fix is provided in next version.

Team is working on permanent solution as we speak.

Best regards,
Shindiri Studio | http://www.shindiristudio.com/

uktw Client

Ok, that will be causing the problem as the timeline is loaded via a custom shortcode I built and so is simply

<?php do_shortcode('[content_timeline id="1"]'); ?>

I just need a way of forcing the loading of scripts/css ;-)

Thanks for the fast response by the way


uktw Client

ok, fixed the basic problem by moving the [content_timeline id="1"] into the shortcode content and displaying it from there as your code now detects the presence of the shortcode on the page

BUT

"read more" doesn't work, it slides open teh box but you just get the loading bar ...

https://www.gsmautomotive.com/company/company-history/

uktw Client

What I get is 

POST https://www.gsmautomotive.com/wp-admin/admin-ajax.php?action=ctimeline_frontend_get&timeline=1&id=so... 403

A mod_security rule has been set to forbid this because of a vulnerability outlined in CVE-2017-14507

Shindiri Support team Administrator

Hi,

did you manage to sort the warning/error for open content as here when we check the read more works just fine check this screenshot:  http://prntscr.com/ndk2z7

Also there is no error 403 present via console check.

Best regards,
Shindiri Studio | http://www.shindiristudio.com/

uktw Client

Yes, but I had to get the hosting company to remove the mod_security.c check for that vulnerability - so can you check, fix and update ;-) Many thanks

Shindiri Support team Administrator

Hi,

we checked and its the same security vulnerability we sorted and updated in version 4.4.3 so don't worry about that one.  That mod_security.c should be updated and removed for all versions after 4.4.3 actually.

Thank you.

Best regards,
Shindiri Studio | http://www.shindiristudio.com/

× This ticket is closed.